Commit f243bb30 authored by Nigel Kukard's avatar Nigel Kukard
Browse files

* Adjusted versioning for required libs

* Automake 1.7 can be used
* Fixed "bug" in xml cflags determination
* Removed some crud that made its way into lib/Makefile.am
parent 5830d8c8
......@@ -32,6 +32,9 @@ AC_ARG_ENABLE(glibtest, [ --disable-glibtest do not try to compile and run
gmodule)
pkg_config_args="$pkg_config_args gmodule-2.0"
;;
gmodule-no-export)
pkg_config_args="$pkg_config_args gmodule-no-export-2.0"
;;
gobject)
pkg_config_args="$pkg_config_args gobject-2.0"
;;
......
......@@ -22753,7 +22753,7 @@ fi
done
 
 
# Check for glib 2.4.0
# Check for glib 2.2.0
# Check whether --enable-glibtest or --disable-glibtest was given.
if test "${enable_glibtest+set}" = set; then
enableval="$enable_glibtest"
......@@ -22769,6 +22769,9 @@ fi;
gmodule)
pkg_config_args="$pkg_config_args gmodule-2.0"
;;
gmodule-no-export)
pkg_config_args="$pkg_config_args gmodule-no-export-2.0"
;;
gobject)
pkg_config_args="$pkg_config_args gobject-2.0"
;;
......@@ -22833,7 +22836,7 @@ fi
no_glib=yes
fi
 
min_glib_version=2.4.0
min_glib_version=2.2.0
echo "$as_me:$LINENO: checking for GLIB - version >= $min_glib_version" >&5
echo $ECHO_N "checking for GLIB - version >= $min_glib_version... $ECHO_C" >&6
 
......@@ -23077,11 +23080,11 @@ if test x"$have_glib" = x"no"
then
echo
echo "* - ERROR -"
echo "* glib >= 2.4.0 required, this includes the development libraries and headers"
echo "* glib >= 2.2.0 required, this includes the development libraries and headers"
exit 1
fi
 
# Check for libxml 2.6.0
# Check for libxml 2.5.0
 
 
# Check whether --with-xml-prefix or --without-xml-prefix was given.
......@@ -23160,7 +23163,7 @@ else
echo "${ECHO_T}no" >&6
fi
 
min_xml_version=2.6.0
min_xml_version=2.5.0
echo "$as_me:$LINENO: checking for libxml - version >= $min_xml_version" >&5
echo $ECHO_N "checking for libxml - version >= $min_xml_version... $ECHO_C" >&6
no_xml=""
......@@ -23390,7 +23393,7 @@ if test x"$have_xml" = x"no"
then
echo
echo "* - ERROR -"
echo "* libxml >= 2.6.0 required, this includes the development libraries and headers"
echo "* libxml >= 2.5.0 required, this includes the development libraries and headers"
exit 1
fi
 
......
......@@ -26,7 +26,7 @@ AC_CONFIG_HEADER([config.h])
AC_GNU_SOURCE
AM_INIT_AUTOMAKE(1.8)
AM_INIT_AUTOMAKE(1.7)
# Checks for programs.
......@@ -95,27 +95,30 @@ AC_FUNC_STRFTIME
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([gettimeofday inet_ntoa memset select socket strcasecmp strchr strdup strerror strncasecmp strndup])
# Check for glib 2.4.0
AM_PATH_GLIB_2_0(2.4.0,have_glib=yes,have_glib=no,gthread)
# Check for glib 2.2.0
AM_PATH_GLIB_2_0(2.2.0,have_glib=yes,have_glib=no,gthread)
if test x"$have_glib" = x"no"
then
echo
echo "* - ERROR -"
echo "* glib >= 2.4.0 required, this includes the development libraries and headers"
echo "* glib >= 2.2.0 required, this includes the development libraries and headers"
exit 1
fi
# Check for libxml 2.6.0
AM_PATH_XML2(2.6.0,have_xml=yes,have_xml=no)
# Check for libxml 2.5.0
AM_PATH_XML2(2.5.0,have_xml=yes,have_xml=no)
if test x"$have_xml" = x"no"
then
echo
echo "* - ERROR -"
echo "* libxml >= 2.6.0 required, this includes the development libraries and headers"
echo "* libxml >= 2.5.0 required, this includes the development libraries and headers"
exit 1
fi
XML_CFLAGS=$XML_CPPFLAGS
if test x"$XML_CFLAGS" = x
then
XML_CFLAGS=$XML_CPPFLAGS
fi
AC_SUBST(XML_CFLAGS)
......
@set UPDATED 10 January 2005
@set UPDATED 19 January 2005
@set UPDATED-MONTH January 2005
@set EDITION devel
@set VERSION devel
@set UPDATED 10 January 2005
@set UPDATED 19 January 2005
@set UPDATED-MONTH January 2005
@set EDITION devel
@set VERSION devel
......@@ -26,6 +26,6 @@ XML_CFLAGS=@XML_CFLAGS@
lib_LTLIBRARIES = libbwm.la
libbwm_la_SOURCES = xmlConf.c misc.c
libbwm_la_CFLAGS = -I$(top_srcdir)/include $(GLIB_CFLAGS) $(XML_CFLAGS) $(GMIME_CFLAGS) $(AM_CFLAGS)
libbwm_la_LDFLAGS = $(GLIB_LIBS) $(XML_LIBS) $(GMIME_LIBS) -version-info 1:0:0
libbwm_la_CFLAGS = -I$(top_srcdir)/include $(GLIB_CFLAGS) $(XML_CFLAGS) $(AM_CFLAGS)
libbwm_la_LDFLAGS = $(GLIB_LIBS) $(XML_LIBS) -version-info 1:0:0
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment